
Dreamweaver CS6 Text 

In this lesson you will learn how to work with headings, paragraphs and other text elements in Dreamweaver and to do the 

following: 

 Enter headings and paragraph text 

 Include text from another source 

 Insert ordered and unordered lists 

 Spell check your document 

 Search and replace text 

 Insert and modify tables 

 Import tabular data 

This lesson will take about 90 minutes to complete.  Be sure you have copied dw_text folder from the website to your computer 

hard drive in to a folder called dw_text in your My Doucments folder.   As you work on this lesson you will make changes to the files.  

If you need to restore them you can copy them again from the dw_text folder.  

 

Preview your completed file – To get a sense of the file you will work on in the first part of this lesson you can preview the 

completed page in the browser. 

1. Start Adobe Dreamweaver CS6. 

2. Choose Dreamweaver Site in the Create New column 

3. In the Site Name box type Dreamweaver Text 

4. Click on the file icon and select the dw_text folder you downloaded. 

5. Preview the spirit_final.htm page in Internet Explorer.  Note the variety of text elements used: headings, paragraphs, lists 

and tables. 

6. Close the browser and return to Dreamweaver. 

Entering headings and body text – Whenever you open a document in Dreamweaver, you are ready to enter or modify text. 

7. From the Files panel, double-click the dw_text >spirit.htm file to open it.  The spirit.htm file is an unfinished web page that 

has a mix of placeholder and final text.  You will be replacing the placeholder text and formatting the final text in this 

lesson. 

8. Select the phrase below the main navigation bar.  Placeholder heading, and press Delete.  Enter the phrase Driven by 

imagination.  By default, test in initially entered unformatted.  You can easily assign a basic format such as a <h1>, <h2>, or 

<p> tag to any text through the Property inspector. 

9. If necessary, choose Window > Properties to display the Property inspector.  With your cursor still in the newly-entered 

text, choose Heading 1 from the Format list in the Property inspector.  Because an external style sheet is already attached 

to this Web page, the text takes on the assigned color, font and size of the CSS rule for h1 headings.  You can see these 

displayed in the Property inspector. 

10. Place your cursor above the heading, Ahead of the curve, and enter the phrase Our reality is visionary.  In the Property 

inspector choose Heading 2 from the Format list. 

11. With your cursor at the end of the text you just entered, press Enter.  Enter the following paragraph: 

We strive to move beyond the ordinary, every day.  For us, the extraordinary is standard in whatever we do.  

Communicate your dreams to us and we’ll bring them to life, more vivid than you ever thought possible. 

12. Select the second sentence in the paragraph you just entered:  For us, the extraordinary is standard in whatever we do.  

Be sure to include the space following the period.  Drag it to the end of the paragraph after the phrase … ever thought 

possible.  Press Left+arrow to move your cursor to the beginning of the moved sentence and press the space bar. 

13. So far, all of your work on this page has been with a single tag, either <h1>, <h2>, or <p> tag.  If you split a paragraph into 

two parts, Dreamweaver automatically creates the additional tag for you. 

14. Place your cursor in the paragraph below the heading Ahead of the curve, in front of the second sentence that starts 

However, the dev/design crew and press Enter. 

15. Choose File > Save. 

Importing external text - Although Dreamweaver provides excellent word processing support, web designers often need to insert 

text created in an external application, like Microsoft Word.  Dreamweaver offers a range of options for inserting text from an 
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outside source, including copying and pasting, drag and drop, and linking.  In this exercise, you’ll insert a document created in Word 

by dragging it onto the page and selecting the proper option. 

16. If necessary, re-open the spirit.htm file you worked on in the previous exercise by double-clicking its entry in the Files panel. 

17. Select the placeholder paragraph in the column on the right side of the page and press Delete. 

18. The inserted text will be added at the top of the right column.  In the Files panel, expand the dw_text assets folder.  

19. Drag the Spirit_text.doc file from the Files panel and drop it on the web page in the current cursor position.  When you drop 

your dragged file, Dreamweaver recognizes the file as a Word document and opens the Insert Text dialog box.  This dialog 

box presents a range of paste options from basic text to full formatting, along with an opportunity to insert a link to the 

external document. 

20. In the Insert Text dialog box, select the Insert the contents option and the Text with structure plus basic formatting (bold, 

italic) option. Click OK when you’re done.  This option is chosen because the current web page already has styles applied; if 

the Text with structure plus full formatting option were selected, the Word styles would be included and would need to be 

removed.  Dreamweaver retains all of the paragraph breaks along with the italicized styling of the phrase esprit de corps;  if 

you place your cursor within that phrase, you will note that the Tag Selector indicates that the proper HTML <em> or 

emphasis tag is used.  Dreamweaver automatically converts italics to <em> tags and bold to <strong> tags when inserting 

test from external applications. 

21. Choose File > Save. 

Creating Numbered and Bulleted lists 

22. If necessary re-open the spirit.htm file that you worked on in the previous lesson by double-clicking on the file in the Files 

panel. 

23. Select the four single-line paragraphs starting with Through pre-planning and ending with Realized return on investment. 

24. From the Property inspector, click Ordered list ( ). 

25. Place your cursor in the third entry, Creative back-and-forth, From the Tag Selector, choose <li> and cut the selection to the 

clipboard. 

26. Press Up-arrow once to move your cursor in front of the second entry and paste the clipboard contents. 

27. It is very easy to switch from one type of list to another.  From the Tag Selector, choose <ol>.  In the Property inspector, 

click Unordered list ( ). 

28. Place your cursor in any of the items of the bulleted list and choose Window > CSS Styles.  In the CSS Styles panel, click  

Current to switch to Current mode.  In the Rules panel, select ul li and click Edit Style.  When the CSS Rule Definition for ul li 

in main.css dialog box opens click List in the Category area.  From the Type menu, choose disc and click OK. 

29. Choose File > Save All to store changes to the HTML and CSS files. 

Spell checking your document 

30. If necessary re-open the spirit.htm file worked on in the previous exercise by double-clicking its entry in the Files panel. 

31. Place your cursor in the <h1> heading, Driven by imagination, and press Ctrl+Home to move the cursor to the top of the 

page. 

32. Dreamweaver starts the spell check operation from the current cursor position and when it reaches the end of the 

document offers to start again from the top, if necessary.  By positioning the cursor at the top of the document this step is 

avoided.  Choose Text > Check Spelling. 

33. With the first entry in the Suggestion list selected, motivate, click Change.  After the next spelling error is located, click 

Change to replace the work not found in the dictionary with the correct suggestion.  Repeat this process until all incorrectly 

spelled words are replaced.  When Dreamweaver notes that the spelling check is complete click OK.  Choose File > Save. 

Searching and replacing text 

34. If necessary re-open the spirit.htm file by clicking on the file name in the Files panel. 

35. Choose Edit > Find and Replace.  When the Find and Replace dialog box opens, from the Find in list, choose Current 

Document and from the Search list, choose Text. 

36. In the Find field, enter the phrase dev/design and click Find Next. 

37. Dreamweaver locates the first instance of the phrase.  With the Find Next option, you can examine each found instance and 

determine if it should be replaced. 
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38. In the Replace field enter the phrase div / design (adding a space before and after the /) and click Replace.  Dreamweaver 

replaces the first instance of the found phrase and immediately searches for the next instances in the Search category, 

double-click the second entry to locate it on the web page. 

39. Click the green arrow on the side of the Search panel.  In the Find and Replace dialog box, click Replace All. 

40. After the Find and Replace operation is complete Dreamweaver automatically closes the dialog box.  The results of the 

operation are displayed in the bottom of the Results panel.  In this exercise, you should see: Done.2 items found.2 replaced 

in the current document. 

Building Tables  Tables are an effective tool for presenting structured data in a series of rows and columns.  Dreamweaver provides a 

table object that is easily inserted and just as easily modified, both in Design view and through the Property inspector. 

41. If necessary re-open the spirit.htm file worked on in the previous lesson by double-clicking on the file name in the Files 

panel. 

42. Place your cursor on the line below the lower right column paragraph that starts The dev / design teams brings fresh ideas. 

43. From the Insert bar’s Common category, choose Table. 

44. When the Table dialog box opens, in the Row field enter 4.  Press Tab and enter 2 in the Columns field.  In the Table width 

field, enter 100; press Tab and choose percent from the Table width list.   Enter 0 in the Border thickness field and press 

Tab.  Finally choose Top from the Header area and click OK. 

45. The table that was specified in the previous step is inserted in the web page at the current cursor location, ready for data or 

editing.  Because the 100% width was used, the table expands to fill the column. 

46. In the first cell of the table (row 1, column 1), enter Team.  Press Tab and enter Experience in the top row, right column.  

Press Tab again to move to the second row. 

47. Enter the following text in the table as shown below: 

Graphics 18 years 

Interactive 27 years 

Copywriting 23 years 

48. Often the number of rows and/or columns that initially defines a table needs to be modified.  Dreamweaver offers a 

number of ways to make this change.  Add another row with one of the more flexible methods.  From the Tag Selector 

choose <table>.  In the Property inspector, change the Rows value from 4 to 5 and press Tab. 

49. The new row is added to the bottom of the table.  If you were to increase the number of columns, the new column would 

be added to the right side of the table. 

50. In the new row enter Management and press Tab.  Enter 32 years in the last table cell. 

51. Dreamweaver uses table header <th> tags for any designated header cells.  This makes them easy to style using CSS. 

52. If necessary choose Windows > CSS Styles.  From the CSS Styles panel choose New Rule.  In the New CSS Rule dialog box, 

select the Selector Type: Tag option and enter th in the Tag field.  Make  sure that the Define in: option is set to main.css 

and click OK. 

53. When the CSS Rule Definition for th in main.css dialog box appears, click Block in the Category list.  From the Text align list, 

choose left and click OK.  By default, browsers render the <th> tags centered and bold.  The new style rule shifts the 

alignment to the left, but maintains the bold format. 

54. Choose File > Save and press F12 to preview the page in your primary browser.  When you’re done, close your browser and 

return to Dreamweaver and choose File > Close. 

Importing Tabular Data  In addition to working with text from word processing programs, Dreamweaver also has the capacity to 

incorporate tabular data from a spreadsheet or database program.  To be imported into Dreamweaver, the data must be stored in a 

tab-delimited or comma separated format.  On import, the data is inserted into Dreamweaver in a table which can be styled or 

edited. 

55. In the Files panel, double-click the folks_maya.htm file to open it. 

56. Place your cursor in the right-side column on the line underneath the heading Unconventional resume. 

57. Choose File > Import > Tabular Data.  In the Import Tabular Data dialog box, click the Browse button.  When the Open dialog 

box appears, navigate to the dw_text  > assets folder and select the interview.csv file; click Open to confirm your choice and 

close the Open dialog box. 
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58. From the Delimiter list, choose Tab. Choose the Table width: Set to option and enter 100 in the associated field and select 

Percent from the list.  In the Border field enter 0; click OK when you’re done.  Dreamweaver inserts a table containing the 

tabular data on the page, ready for customization.  The first column is a bit narrow, so let’s widen it to fix all the entries on 

a single line. 

59. Place your cursor in the first cell of the inserted table which contains the phrase Art influences.  If necessary choose 

Window > Properties to display the Properties inspector.  In the W (Width) field enter 35% and press Tab. 

60. The top cell of any column controls the width for the column; you could have also modified the width by dragging the 

column border to a new position.  Now, let’s apply a style to all of the cells in the column. 

61. With your cursor in the first cell of the left column, drag your mouse down the entire column to select all of the cells.  In the 

Property inspector, choose interviewHeader from the Style list.  Click anywhere on the page to clear the selection. 

62. The interviewHeader style makes the text bold, right-aligned and vertically aligned to the top. 

63. Choose File > Save and press F12 to preview the page in your primary browser.  When you’re done, close your browser and 

return to Dreamweaver and choose File > Close 

64. Show the instructor your web page to get credit for the assignment. 


