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In this lesson you will learn how to include images in your web pages by doing the following: 

 Insert an image 

 Apply a background image 

 Optimize an incorporated image 

 Add Adobe Fireworks rollovers to a page 

 Import an Adobe Photoshop file 

 Copy and paste an image from Photoshop 

 

This lesson will take about 90 minutes to complete.  Be sure you have copied the Dreamweaver CSS files from the class website to 

your computer hard drive in to a folder called dw_image in your dw_cib folder.   As you work on this lesson you will make changes to 

the files.  If you need to restore them you can copy them again from the website.  

 

Preview your completed file – To get a sense of the file you will work on in the first part of this lesson you can preview the 

completed page in the browser. 

1. Start Adobe Dreamweaver CS6. 

2. If necessary, press F8 to open the Files panel and choose DW CIB from the site list. 

3. In the Files panel expand the dw_image folder. 

4. Select the images_final.htm file.  This is what your finished web page will look like. 

5. Press F12 to preview the page in a web browser.  The page includes a number of images, both foreground and background, 

as well as Fireworks-generated rollovers in the navigation bar. 

Inserting an image – Images are a key component of any web page.  Dreamweaver makes it easy to insert web graphics in a number 

of ways, as you’ll learn in this exercise. 

6. From the Files panel, double-click the dw_image > images_start.htm file to open it.  Placeholder images are used to indicate 

where some of the graphics will be inserted during this lesson. 

7. Select the Banner placeholder image and press Delete. 

8. From the Insert tab at the top of your Dreamweaver window choose image.   

9. When the Select Image Source dialog box appears, navigate to the dw_image > images folder and select boat.  Click OK. 

10. To make sure your pages are accessible to site visitors using screen readers or other assistive technologies, it is a good idea 

to always add appropriate alternative text to any inserted image. 

11. With the boat image selected, enter Red rowboat by the side of a river in the Alt field of the Property inspector and press 

Tab. 

12. Another way to add an image is to use the Assets panel.  Choose the Assets tab at the top of the Files panel, click the 

Images button and Images category, the top icon in the column on the left of the panel.  Scroll down to locate and select 

the streetlights.jpg image. 

13. Drag the image preview from the Assets panel to the Document window and drop it in front of the first paragraph of the 

left column below the heading that reads Bringing light to the dark. 

14. In the Alt field in the Property inspector, enter Streetlights along a road at night.  Choose File > Save. 

Using background images – Web pages can incorporate two different types of images:  foreground and background.  Foreground 

images are web graphics (JPG, GIF,  or PNG format) that are added to the document as an <img> tag; the previous exercise inserted 

two foreground images.  Background images, on the other hand, are included in the page through CSS. 

15. Select the logo image placeholder and press Delete. 

16. Choose Window > CSS Styles and if necessary, click All to enter All mode. 

17. In the main.css listing, choose #logo and click Edit Style. 

18. When the CSS Rule Definition for #logo in main.css dialog box opens, click Background in the Category list. 

19. Click Browse and, in the Select Image Source dialog box, navigate to the dw_image > images folder and select logo.gif. 

20. From the Repeat list, choose no-repeat and click OK. 

21. By default, background images tile, both horizontally and vertically to fill the container space.  To display an image once, as 

desired here, you must specify the no-repeat value.  Choose File > Save All. 
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22. Because the #logo CSS style rule is stored in an external style sheet, Dreamweaver automatically opens the file to change 

the style.  Both the main document and the style sheet must be saved to store the current document look-and-feel. 

Optimizing graphics – The optimum web graphic balances image clarity with file size.  It is not uncommon for the web designer to 

need to optimize graphics that have already been placed on the page.  Dreamweaver includes a graphics engine that is good for 

getting the best image at the lowest possible file size.  In this exercise, you will use Dreamweaver’s built-in tools to optimize  an 

image for the web as well as rescale the graphic. 

23. Place your cursor in front of the second paragraph of the right-side column, before the placeholder phrase Lorem ipsum 

dolor sit amet. 

24. From the Insert tab, choose Image. 

25. When the Select Image Source dialog box opens, navigate to the dw_image > images folder and choose gears.jpg.  Click OK 

26. In the Alternate text box enter Gears and click OK 

27. Not only is this graphic too big for the column area, at 103K it is also quite large in file size.  Before rescaling to a more page-

appropriate size, and a more web-friendly file size, align the image to the right with a pre-defined CSS class. 

28. With the gears.jpg image selected, right click on the <img> tag in the tag selector, choose Set Class and choose imageRight 

from the Class list. 

29. Images can be resized by dragging any of the three sizing handles found on a selected graphic.  Images resized in 

Dreamweaver by this technique are not actually rescaled but merely re-rendered with different dimensions.  To resize and 

optimize an image you need to apply the Optimize command. 

30. Begin to resize the gears.jpg image by dragging the handle of the lower-right corner.  While dragging, press and hold the 

Shift key to maintain the original width/height ratio.  When you have reduced the image to approximately 2/3 the original 

size, release your mouse first then release the Shift key.  Look in the Property inspector and notice that the new width 

should be 125 and the height 188. 

31. Now the graphic fits better in the page, now you can optimize it to reduce the file size and resample the image for the new 

smaller size. 

32. With the gear.jpg image selected, click the Commands tab and choose Optimize Image.  When the Image Preview dialog 

box opens, make sure JPEG is chosen from the Format list.  Click and drag the Quality slider to 80.  The higher the quality , 

the more detailed the image and the greater the file size.  Click OK  

33. Choose File > Save 

Including Frieworks rollovers 

34. Navigation bars are common web page elements comprised of a series of sliced graphical images and links in a single 

unified structure.  The containing structure is often an HTML table.  With Fireworks, you can create the entire navigation 

bar in a graphical environment – complete with links – and easily import it into Dreamweaver in a single operation. 

35. Right click in the Navigation place holder image and choose Create Image in Fireworks to open Fireworks CS6 

36. When Fireworks opens, choose File > Open.  When the Open dialog box appears, navigate to the dw_image > source folder 

and select navbar.png.  Click open. 

37. Choose File > Export.  When the Export dialog box opens, navigate to the dw_image > images folder.  The key to 

successfully exporting a sliced image from Fireworks for import into Dreamweaver is to export both the HTML and the 

images; Fireworks has a setting for this purpose. 

38. Leave the default entry, navbar, in the File name field and make sure that HTML and Images is chosen from the Export list.  

From the HTML list, choose Export HTML File and, from the Slices list, choose Export Slices. Choose the Include areas 

without slices option, and the Put images in subfolder option. 

39. Because slicing a graphic can result in a great deal of similarly named images, it is a good idea to keep all of the sliced 

images in their own subfolder.  For example, the export of the navbar.png file results in 25 separate images.  By default, 

Fireworks suggests the folder name images; to avoid confusion, let’s name the folder navbar. 

40. Click Browse to select a new subfolder.  When the Select Folder dialog box opens, navigate to the dw_image > images > 

navbar folder and click Save “navbar”.  Once you have returned to the Export dialog box, click Save. 

41. Choose File > Save and close Fireworks. 

42. Reopen Dreamweaver CS6. 
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43. From the Files panel navigate to the dw_image folder and open the images_start.htm file. 

44. Select the placeholder image Navigation and press Delete. 

45. In the Insert tab of the Insert bar, choose Image Objects, Fireworks HTML from the Images menu button. 

46. When the Insert Fireworks HTML dialog box opens, click Browse to open the Select the Fireworks HTML file dialog box.  

Navigate to the dw_image > images folder and select navbar.htm; click Open to confirm your choice.  When the Insert 

Fireworks HTML dialog box reappears, leave the Delete file after insertion option unchecked and click OK. 

47. Dreamweaver reads the code from the Fireworks HTML file and inserts just the required table structure.  Additionally, the 

referenced graphics are preloaded to prevent the page from displaying without all of the images available.  Choose File > 

Save All. Press F12 to view the page in a browser. 

Inserting Photoshop files. 

48. From the Files panel, navigate to the dw_image folder and double-click the ps_bridge_start.htm file to open it. 

49. Place the cursor before the first paragraph in the left column that starts We strive to move beyond the ordinary. 

50. In the Insert tab, click Image from the Images menu button. 

51. When the Select Image Source dialog box opens, navigate to the dw_image > source folder and select our_world.psd; click 

OK. 

52. When the Image Preview dialog box is displayed, drag the Quality slider to 60 and click OK. Click Save  In the Alternate text 

box enter World 

53. In the Property Inspector, make sure the Constrain option is selected and enter 360 in the Width field and 240 in the Height 

field. 

54. The newly-saved graphic is automatically inserted into the document at the current cursor position.  Choose File > Save All. 

Copying and Pasting from Photoshop 

55. Many web designers use Photoshop to initially compose their site layouts.  To create the actual Dreamweaver layout, only 

portions of the Photoshop graphics are needed; other page elements are text or CSS based.  With Photoshop CS6 and 

Dreamweaver CS6, it is easy to copy any needed selection in from the graphic comp in Photoshop and paste it into the 

Dreamweaver layout.  The Preview dialog box acts as the intermediary to convert the file to the necessary format. 

56. Re-open the ps_bridge_start.htm file that you worked on in the previous lesson by double-clicking the file name in the Files 

panel. 

57. Place your cursor before the start of the paragraph in the right-side column that starts We want you involved in your re-

design.   

58. Start Adobe Photoshop CS6 from the Adobe Web Premium CS6 folder in your start menu.   

59. Choose File > Open.  When the Open dialog box appears, navigate to the dw_image > source folder and select 

company_history.psd.  Click Open. 

60. The file opened is a comp for a different website.  In this exercise, you will select a portion of a photo to use in 

Dreamweaver. 

61. From the Tools palette, select Rectangular Marquee tool and drag a rectangle around a selection within the purple border 

that includes the two pairs of legs on the left of the image. 

62. Choose Edit > Copy.  Close Photoshop without saving the image and return to Dreamweaver. 

63. In Dreamweaver, choose Edit > Paste.  When the Image Preview dialog box opens, make sure that JPEG – Better Quality is 

chosen from the Saved Settings list and click OK. 

64. When the Save Web Image dialog box opens, navigate to the dw_image > images folder.  In the File name field, enter 

jump.jpg and click Save.  In the Image description (Alt Test) box enter Jumping legs. Click OK.  The image copied from 

Photoshop is inserted into the document.   

65. Select the newly inserted image and right click the <img> tag in the tag selector, choose Set Class and imageRight from the 

Class list.  Choose File > Save All. 

66. Show your finished activity to the instructor. 


